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1 Automation Net PVI 

1.1 소개 

B&R Automation Net 은 사용자에게 PC 와 B&R 컨트롤 시스템을 유연하고 쉽게 통신을 할 수 있는 

해결책을 제공합니다. Automation Net PVI(Process Visualization Interface)는간단하게 B&R 컨트롤러와 

Visualization 사이에서 데이터를 주고받는 것에서 복잡한 클라이언트, 서버 어플리케이션까지 가능합니다.  

Automation Studio 는 이러한 PVI 요소들을 사용합니다. 변수 모니터를 통해 간단한 변수값을 바꾸거나 

B&R 컨트롤러에 모든 프로젝트를 전송할 수 있습니다. PVI 는 컨트롤러 시간 설정과 같은 일반적인 

기능을 다룰 수 있습니다. 

 

 

 

 

Automation Net–PVI 에 접근은 윈도우 기반의 소프트웨어를 PVI 에 연결하여 사용할 수 있는 많은 

인터페이스를 유저에게 제공합니다. PVI 함수를 가지고 프로그래밍 하는 것부터 PVI 어플리케이션 

파라미터 셋팅 및  구성까지 제공됩니다. 

1.2 B&R Automation Net 

B&R Automation Net 은 윈도우 기반의 산업용 PC, 드라이버, 컨트롤러, Operating Panel 그리고 

프로그래밍 툴 사이의 광범위한 통신을 완벽하게 제공합니다. 
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1.2.1 Automation Net 에 접근하기 

컨트롤러는 CPU 사이에서 독립적인 데이터 교환을 위해 다양한 변수를 사용자에게 제공합니다. 

윈도우에서 PVI 는 프로토콜과 미디어의 독립적인 CPU 와 PC 사이에서 데이터를 교환하기 위해 

사용됩니다. 

PVI 컨셉은 3 부분으로 나눌 수 있습니다. 

 

 PVI clients (윈도우 어플리케이션) 

 데이터 처리를 관리하는 PVI component (PVI 매니저) 

 통신타입(protocol)과 통신 미디어를 관리를 위한 PVI 라인 

 

 

 

여러 개의 PVI 어플리케이션은 사용되어지고 있는 독립적인 통신타입을 동시에 실행할 수 있습니다. 

즉, 이러한 통신은 데이터를 주고 받는데 제한이 없다는 것을 의미합니다. 추가적으로 PVI 서비스는 

다양한 어플리케이션으로 사용될 수 있습니다. 
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1.2.2 Automation Net 윈도우 인터페이스 

윈도우 XP / Vista / 7 또는 윈도우 CE 를 사용하는 환경에서 PVI 기반의 시스템은 B&R Automation Net 을 

위한 중요한 접근 채널입니다. 

모든 윈도우 기반의 소프트웨어를 위해 PVI 는 전 세계 B&R 산업용 PC 에 공통된 인터페이스를 제공합니다. 

 

 

 

1.2.3 PVI Manager 

PVI 매니저(PVI 중앙 컴포넌트)는 간단한 변수부터 리스트, 프로그램 또는 데이터 모듈까지 프로세스 데이터 

안에 모든 타입의 매니지먼트를 관리합니다. 

PVI 매니저는 타이밍과 방향에 관한 프로세스 데이터로 구성되어 있습니다. 이것은 PVI 매니저가 유저 

configuration(방향, 프로토콜, 전달매체, 장치 등)으로부터 데이터 전송을 조작한다는 것을 의미합니다. 
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다른 Task 들 사이에서 Network delay 를 맞추거나 지정된 이벤트를 처리하기 위해 특정 경고가 비동기화 

매니지먼트에 전달됩니다. 

 

PVI 매니저의 특징: 

 중앙 PVI 컴포넌트 

 객체지향적이고 체계적인 프로세스 데이터 관리 

 같은 타이밍, 같은 뱡향을 기반으로 하는 프로세스 데이터 관리 

 클라이언트 / 서버 구조를 통한 다중 프로세스관리 및 스테이션 관리 

 데이터 변형, 선형화 

 이벤트 처리 데이터 획득 

 PVI object 의 연결에 대한 종류 

 프로그래밍 언어 및 윈도우 플렛폼의 독립화 

 확장이 용이한 런타임 시스템 

 

1.2.4 PVICOM 인터페이스 

PVICOM 인터페이스(클라이언트 인터페이스)는 가장 낮은 레벨부터 PVI 에 접근하도록 되어있습니다. 

이것은 가장 최적의 PVI 인터페이스를 작동하는데 있어서 적합하다는 것을 나타냅니다. 

PVI 인터페이스는 PVI 접근권한(PVI OPC, PVI DDE, PVI 서비스 등)을 가지고 있는 모든 윈도우 기반의 

컴포넌트에 의해 사용되어 집니다.ㄷ 
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PVICOM 인터페이스는 클라이언트/서버 규칙에 맞춰 작동합니다. PVI 매니저는 서버처럼 작동하고 PVICOM 

어플리케이션은 클라이언트 입니다. 서버와 클라이언트는 같은 기계에 있을수도 있고(로컬 통신 방식) 또는 

다른 컴퓨터에 있을수도 있습니다.(원격 통신 방식) 

 

1.2.5 PVI 라이센스 

B&R PC 에서는 추가적인 런타임 라이선스 없이 PVI 를 작동시킬 수 있습니다. 

다른 구조(LPT, USB, company license DLL)의 PC 에서는 동글(dongle, License)이 필요합니다.  

PVI 라이센스가 없는 경우 PVI 어플리케이션은 최대 2 시간 동안 기능에 제한 없이 작동이 가능합니다. 

 5S0500.02 (LPT) 

 5S0500.02U (USB) 

 5S0500.99 (company license DLL) 

PVI 런타임 라이센스는 PVI 매니저가 작동 중인 PC 에서만 필요합니다. 원격 PVI 를 통해 PVI 가 설치된 

서버 PC 에 접속하는 클라이언트 PC 의 어플리케이션에는 추가로 PVI 런타임 라이센스가 필요하지 않습니다. 

 

PVI 라이센스 관련된 상세한 사항은 B&R 에 문의 부탁드립니다. 

 

1.3 AUTOMATION NET - PVI 라인 

PVICOM 인터페이스의 접근은 프로토콜이나 사용되고 있는 매체와 관계가 없습니다. 

PVI 라인의 기본적인 역할은 PVI Object 와 PVI 외부의 Object 를 연결하는 것입니다. 이 라인은 B&R 

컨트롤러와 함께 통신을 책임지고 사용하기 위한 통신 프로토콜을 결정합니다. 
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지원되는 프로토콜 / PVI 라인: 

 INA2000 line (System 2000 온라인 프로토콜) 

 SNMP line 

 NET2000 line 

 CANdirect line 

 MININET line 

 ARCNET OS9 line 

 MTC line / ADI line 

 

 

 

 

 

 

 

 

1.4 PVI 클라이언트 프로그래밍 

PVICOM 인터페이스를 통하는 통신은 PVI 통신 라이브러리 “PviCom.dll”안에 있는 펑션과 함께 다뤄집니다. 

PVI 통신 라이브러리는 윈도우 스탠다드의 기반의 DLL(Dynamic Link Library)입니다. 

프로그래밍 환경에 따라 PVICOM 인터페이스 함수는 직접적으로 사용되거나 각각의 함수로 압축된 유저 

컨트롤로 제공이 됩니다. 
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1.4.1 PVICOM.DLL 

32-bit 사용하는 프로그래밍 환경은 다음과 같습니다. 

 Visual C++ (Version 6.0 and up) 

 Visual Basic (Version 6.0 and up) 

 Borland C++ Builder (Version 3 and up) 

 Borland Delpji (Version 4 and up) 

 

PviCom.dll 은 PVI 기능을 통해 접근됩니다. 정의된 파일이나 선언한 파일의 동기화 시키는 것이 아래 각각의 

프로그래밍 환경에서 가능합니다. 

 Pvilnitialize(...) 

 PviCreate(...), PviLink(...) 

 PviReadRequest(...) 

 PviReadResponse(...) 

 PviWriteRequest(...) 

 PviWriteResponse(...) 

 PviDelete(...), PviUnlink(...) 

 PviDeinitialize(...) 

 

윈도우 CE 에서 PVI Service 컴포넌트는 .NET 개발 환경을 사용할 수 있습니다. 

 

1.4.2 PVI 서비스 

PVI 서비스는 윈도우 32 또는 윈도우 CE 어플리케이션이 있는 B&R 컨트롤러를 위한 Microsoft .NET 개발 

플렛폼에서 PVICOM 컴포넌트를 기반의 진단 서비스나 통신 서비스를 사용 할 수 있게 만들어 줍니다.  

PVICOM 함수 처리방법을 지향하는 Object 는 확실하고 논리적인 처리과정 이미지와 control-specific 

데이터의 결과가 됩니다. 

 

Automation Studio Help  

 Communication > PVI Services 
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2 PVI Development 설치방법 

2.1 PVI Development 구성 내역 

MS Visual Studio 에서 개발한 샘플 소스, DLL 파일과 설명서 및 ‘B&R Automation Studio’가 설치되지 않은 

일반 컴퓨터(PC)에서 PVI 통신을 위한 프로그램이 포함되어 있습니다. 

 

PVI Development 구성 내역 

 PVI Basissystem 

 Runtime Utility Center 

 PVI Development Tools 

 PVI Server 

 PVI Samples 

 OPC Monitor 

 PVI Help 

 
   

2.2 PVI 설치 요구사항 

  

Windows Vista / 7 / 8 Windows XP Windows 2000 

32-bit 64-bit 32-bit 64-bit 

 

Operating system 1) 1) 
 

1) 2) 

Software       

PVI components PviServices applications can be run with any .NET framework version. 

Processor At least Pentium III 650 MHz (recommended: Pentium IV 850 MHz) 

RAM At least 512 MB (depends on the number of process objects) 

Hard drive space At least 300 MB free 

      

1) No CAN communication 
2) Limited USB support for generating CompactFlash data in the Runtime Utility Center 

 



 

PVI 설명서 PVI Development 설치방법 

 

Copyright © B&R - Subject to change without notice 

PVI_매뉴얼_v1.0_20150622.docx 

June 22, 2015 
13/41 

 

2.3 설치파일 다운 받는 위치 

2.3.1 Automation Studio 설치 DVD 

1) Automation Studio 설치 DVD 를 DVD-ROM 에 넣음 

2) 자동 플레이를 누르시거나 Install.exe 를 연속 선택(더블클릭)하여 프로그램을 실행. 

3) 좌측 창에서 ‚Automation Net ‚을 클릭하신 후, ‚Install now‘ 버튼을 선택. 

 

 
 

AS Help(4.2.1.100) GUID: c81bbbee-6172-455d-a4ff-84110491df0e 

Automation software > Software installation > PVI > Installation 

 

2.3.2 B&R 홈페이지에서 다운로드 

http://www.br-automation.com/en/downloads/software/automation-netpvi/pvi-development-setup/ 

 

 

http://www.br-automation.com/en/downloads/software/automation-netpvi/pvi-development-setup/
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1) 다운 받은 파일에서 ‘Install’을 더블클릭 

2) 사용하실 언어 선택 

 
 

3) ‘Install now’를 눌러 설치 시작 

 
 

4) 설치할 프로그램 선택 

PVI Development 와 PVI Runtime 필수 
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샘플 소스 위치  

4 번째 단계에서 ‘PVI Samples’을 선택하셨을 경우 

C:\BrAutomation\PVI\V4.2\Samples\PVI 에 샘플이 설치됩니다. 

설치하신 PVI 버전에 따라 주소 위치가 변경 될 수 있습니다. 
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3 샘플 소스를 이용하여 테스트하기 

3.1 한대의 컴퓨터(PC)에서 시뮬레이션으로 PVI 통신하기 

3.1.1 요구사항 

 필수: Automation Studio 가 설치되고 PVI Sample 이 설치된 컴퓨터(PC) 1 대  

 선택: 동일한컴퓨터(PC)에 VNC viewer  

3.1.2 Automation Studio 에서 Coffee machine 프로젝트 만들기 

1) Automation Studio 첫 페이지에서 샘플 선택 후 실행 

상세한 내용은 Help 참조. 

 
AS Help AS Help(4.2.1.100) GUID: 1eccfc12-bcf9-4157-b862-12f9ee79faed 

Automation software > Example projects > Example projects on the start page 

Automation software > Example projects > CoffeeMachine 

 
 

3.1.3 샘플 소스’PVI Demo’ 실행하기 

아래의 주소에서 PviDemo.exe 프로그램을 클릭하여 실행 

 
C:\BrAutomation\PVI\V4.2\Samples\PVI\Vc\PviDemo\Release 

(설치하신 PVI 버전에 따라 주소 위치가 변경 될 수 있습니다.) 
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3.1.4 PviDemo.exe 설정 안내 

 
 

1) ‘PVI Demo’창에서 Connect 버튼을 클릭 

2)  ‘Connection Parameter for PVI Demo’창에서  ‘Local Communication’을 선택 

 

 
 

3)  ‘OK’ 클릭 

4) ‘PVI Demo’창에서 Object 버튼을 클릭 

5) ‘Objects for PVI Demo’창은 아래와 같이 구성되어 있음. 
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 시뮬레이션은 아래와 같이 CPU 창에 입력. 

PVI Demo 입력 창 관련 설정 

Cpu “/DAIP = 127.0.0.1 /REPO = 11160 / RT = 1000” 

 

 Task 는  Automation Studio 에서 변수가 선언된 Program 이름 

PVI Demo 입력 창 Automation Studio 의 Program 이름 

(Controll 내부에 Program 이름) 

Task brewing 

 
 

 현재 출력되는 변수는 위에서 아래로 gMainLogic.par.recipe.milk, gMainLogic.par.recipe.sugar, 

gMainLogic.par.recipe.coffee, gMainLogic.par.recipe.water 가 출력 됨. 

PVI Demo 출력 창 Automation Studio 에서 선언된 변수 명 

Variable 1 gMainLogic.par.recipe.milk 

Variable 2 gMainLogic.par.recipe.sugar 

Variable 3 gMainLogic.par.recipe.coffee 

Variable 4 gMainLogic.par.recipe.water 
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창안에 있는 각각의 줄은 프로세스 객체(Process object)를 나타냅니다. 

 

통신 프로토콜은 라인 객체(Line object) 를 통해 구체적으로 명시됩니다. 

 Name:  @ / Pvi /  PviDemo 

 Connection description: CD = Lnlna2(name of the line DLL) 

 

장치 객체(Device object)는 PC 와 외부의 물리적인 연결을 정의합니다. 

 Name:  @ / Pvi / PviDemo / ARsim 

 Connection description: CD = “/ IF = tcpip / SA = 1” 

 

스테이션 객체(Station object)는 네트워크 안에 스테이션(Station)을 나타냅니다. 

 Name:   

 Connection description: CD = “” 

 

하나 또는 그 이상의 CPU 객체(CPU object) 는 하나 또는 그 이상의 컨트롤러와 연결입니다. 

 Name:  @ / Pvi / PviDemo / ARsim / Cpu 

 Connection description: CD = “/DAIP = 127.0.0.1 /REPO = 11160 / RT = 1000” 

 

테스크 객체(task object)는 User task 중에서 지역(Local) 또는 전역(global) 변수 가 사용된 테스크입니다.   

 Name:  @ / Pvi / PviDemo / ARsim / Cpu / Brewing 

 Connection description: CD = “brewing” (컨트롤러에 있는 task 이름) 

 

변수 객체( Variable object)는 어떤 데이터 타입과 함께 컨트롤 변수를 나타냅니다. 

 Name:  @ / Pvi / PviDemo / ARsim / Cpu / Brewing / RecipeCoffee 

 Connection description: CD = “gMainLogic.par.recipe.coffee”(“Brewing”task 안에서 사용한 변수) 

 

3.1.5 통신 테스트 수행 순서 

1) Automation Studio 에서 Coffee machine 실행 

2) ‘PviDemo.exe’ 프로그램 실행 

3) VNC 프로그램이 있으면 실행하여 화면 조작으로 커피 종류, 크림(Cream), 설탕(Sugar)를 변경하여 

관련 변수 변경 
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VNC 프로그램이 없을 경우 

Automation Studio 의 ‘Watch’을 이용하여 변수를 직접 변경하여 테스트 가능. 

 
 

4) ‘PviDemo.exe’  화면에서 정상적으로 변수 변경이 되는 것을 확인 

5) 선택: ‘PviDemo.exe’에서 변수 값을 변경하여 B&R PLC 에 변수 변경하기.  

A. ‘PviDemo.exe’에서 변수 값을 변경. 

B. ‘Write’를 클릭  

C. B&R PLC 에서 변수가 변경을 확인 (Watch 또는 VNC viewer 에서 값 확인) 

3.1.6 지역변수 추가 하기 

샘플 프로그램은 전역변수로 테스트한 예시이므로 이번에는 지역변수를 추가해보겠습니다. 

 

1) Automation Studio 프로그램에서 ‘Pvi_Demo’라는 이름의 프로그램 추가 

 
 

2) Pvi_Demo.var 라는 파일에  USINT 타임의 변수 Var1, Var2 를 생성 
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3) INIT 에 변수의 초기 값 설정 

 

4) 하드웨어에 프로그램 전송 

5) Watch 에서 변수 확인 

 

6) Watch 에서 변수 확인 
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7) ‘PviDemo.exe’ 프로그램 실행, Object 클릭 

8) 아래와 같이 설정. 

 
 

9) 프로그램 수행 결과 

Variable 3 과 Variable 4 에서 에러(Error) 가 발생한 이유는 설정한 “Pvi_Demo”라는 Task 안에 

gMainLogic.par.recipe.water 라는 변수와 gMainLogic.par.recipe.sugar 에 대한 변수가 사용되지 

않았기 때문입니다. 

지역변수도 변수가 선언되어 있지 않는 테스크에서 변수에 대한 통신을 시도할 경우 에러(Error)가 

발생합니다. 
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3.2 한대의 PC 와 B&R PLC 간에 PVI 통신하기 

3.2.1 구성도와 요구사항 

TCP/IP 를 이용하여 PVI 통신하기  

 
 

 
PC 

서버 

B&R PLC(X20CP3585) 

클라이언트 

IP address 130.150.0.111 130.150.0.10 

Subnet mask 255.255.255.0 255.255.255.0 

 
 

 PVI 가 설치된 컴퓨터(PC) 1 대  

 B&R PLC (ex. X20CP3585) 1 대  

 랜 (LAN)선으로 PC 와 B&R PLC 와 연결 
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3.2.2 Automation Studio 에서 새로운 프로젝트 생성 

1) 새로운 프로젝트생성 

프로젝트 이름: PVIComm 

2) X20CP3585 로 하드웨어 구성(Hardware configuration) 

 

3) 프로그램 추가 

프로그램 이름: ctrlMain, ctrlSub 

4) 전역변수 및 지역변수 선언 및 소스코딩 

 
 

5) Global.typ 에 구조체 제작 
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6) Global.var 에 변수 선언 

 

 
 

7) 지역변수 선언 

 

 

8) 전역변수 및 지역변수 코딩 
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9) IP 설정 후 CF 카드를 제작 및 PLC 정상 부팅확인 

IP  : 130.150.0.10 
Subnet mask : 255.255.255.0 

 
 

3.2.3 서버 PC 설정 

1) PVI Monitor 실행 

위치:  Start > Programs >  BrAutomation> PviMonitor 

2) PVI Monitor 창에서 Option > Manager Properties 클릭 (또는 <ALT> + <F7> 단축키) 
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3) Use TCP/IP Communication 의 체크박스를 선택 하고 포트넘버를 입력 

  
  

 

경고:  

1024 보다 작은 포트넘버는 윈도우에서 사용됩니다. 10000 보다 큰 포트넘버를 추천합니다. 

 

안내: 관리자 모드 권한이 없어서 열리지 않을 때 

 

PVI Monitor 을 선택한 후 마우스 우클릭 > Run as administrator 선택 후 

관련 설정을 변경 하실 수 있습니다. 
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4) PVI Monitor 종료 후 PVI Monitor 재시작 

PVI 매니저 옵션에서 변경사항은 PVI 매니저가 재시작 된 후에 적용됩니다. 

File> Stop Manager 를 눌러 PVI 매니저를 정지시킨 후, File> Start Manger 를 눌러 다시 시작. 

5) 설정완료 창 확인 

 

Figure 1 설정 전 

   

Figure 2 설정 후 
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3.2.4 ‘PVI Demo’ 프로그램 설정하기(서버   PC) 

1) ‘PviDemo.exe’ 프로그램 실행 

2) ‘Connect’ 클릭 

Remote(TCP/IP) Communication 선택 

IP: PC 의 IP 와 Port 입력 (PVI Manager Properties 에서 설정한 Port 번호) 

 

 
 

3) Object 창에서 CPU 의 Connection 창에 IP 설정 

클라이언트(B&R PLC, X20CP3585)의 IP 입력 

 

4) ‘PVI Demo’ 프로그램을 구동하여 통신 확인 
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4 추가설명 

4.1 Sample 을 실전에서 사용할 시 유의사항. 

PviDemo, PviSimple, PviSimpleCon 은 Coffeemachine 과 연계되어 구동하는 소스입니다. 

이를 아래와 같은 구성에서 (3.2 와 동일한 구성) 사용할 경우 아래와 같은 소스 수정이 필요합니다. 

TCP/IP 를 이용하여 PVI 통신하기  

 
 

 
 

 
 

PVI Demo 

 

‘3.2.4’ 에 ‘PVI Demo’ 설정 참조. 
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PVI Simple 

 

/////////////////////////////////////////////////////////////////////////////// 

// Pvi initialization and objects 

/////////////////////////////////////////////////////////////////////////////// 

// definition of the initialization description:  

static const char g_PviInitDesc[] = "LM=100 COMT=5"; 

 

// definition of all required pvi objects: 

static const T_PVIOBJ_CONFIG g_PviObjList[] = { 

 // line object: 

 { "@Pvi/PviSimple", POBJ_LINE,  

  "CD=LnIna2", "EV=", 

  NULL, NULL }, 

 // device object: 

 { "@Pvi/PviSimple/PLC", POBJ_DEVICE, 

  "CD=\"/IF=tcpip /SA=1\"", "EV=", 

  NULL, NULL }, 

 // cpu object: 

 { "@Pvi/PviSimple/PLC/Cpu", POBJ_CPU, 

  "CD=\"/DAIP=130.150.0.10  /RT=1000\"", "EV=e", 

  NULL, IDC_PVI_STATE_CPU }, 

 // task object: 

 { "@Pvi/PviSimple/PLC/Cpu/ctrlMain", POBJ_TASK, 

  "CD=ctrlMain", "EV=", 

  NULL, NULL }, 

 // variable object 1: 

 { "@Pvi/PviSimple/PLC/Cpu/ctrlMain/nResult", POBJ_PVAR, 

  "CD=nResult RF=250", "VT=string VL=40 EV=ed", 

  IDC_PVI_NAME_PVAR1, IDC_PVI_DATA_PVAR1 }, 

 // variable object 2: 

 { "@Pvi/PviSimple/PLC/Cpu/ctrlMain/nCounter", POBJ_PVAR, 

  "CD=nCounter RF=250", "VT=string VL=40 EV=ed", 

  IDC_PVI_NAME_PVAR2, IDC_PVI_DATA_PVAR2 }, 

 // variable object 3: 

 { "@Pvi/PviSimple/PLC/Cpu/ctrlMain/Coffee", POBJ_PVAR, 

  "CD=gRecipe.Coffee RF=250", "VT=string VL=40 EV=ed", 

  IDC_PVI_NAME_PVAR3, IDC_PVI_DATA_PVAR3 }, 

 // variable object 4: 

 { "@Pvi/PviSimple/PLC/Cpu/ctrlMain/Sugar", POBJ_PVAR, 

  "CD=gRecipe.Sugar RF=250", "VT=string VL=40 EV=ed", 

  IDC_PVI_NAME_PVAR4, IDC_PVI_DATA_PVAR4 }, 

 { NULL } };  // -> end of list indicator 
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PVISimpleCon 

static const T_PVIOBJ_CONFIG g_PviObjList[] = { 

 // line object: 

 { "@Pvi/PviSimple", POBJ_LINE,  

  "CD=LnIna2", "EV=" }, 

 // device object: 

 { "@Pvi/PviSimple/ARsim", POBJ_DEVICE, 

  "CD=\"/IF=tcpip /SA=1\"", "EV=" }, 

 // cpu object: 

 { "@Pvi/PviSimple/ARsim/Cpu", POBJ_CPU, 

  "CD=\"/DAIP=130.150.0.10  /RT=1000\"", "EV=e" }, 

 // task object: 

 { "@Pvi/PviSimple/ARsim/Cpu/ctrlMain", POBJ_TASK, 

  "CD=ctrlMain", "EV=" }, 

 // variable object 1: 

 { "@Pvi/PviSimple/ARsim/Cpu/ctrlMain/nResult", POBJ_PVAR, 

  "CD=nResult RF=2500", "VT=i32 CM=4 EV=ed" }, 

 // variable object 2: 

 { "@Pvi/PviSimple/ARsim/Cpu/ctrlMain/nCounter", POBJ_PVAR, 

  "CD=nCounter RF=2500", "VT=i32 CM=4 EV=ed" }, 

 // variable object 3: 

 { "@Pvi/PviSimple/ARsim/Cpu/ctrlMain/Coffee", POBJ_PVAR, 

  "CD=gRecipe.Coffee RF=2500", "VT=i32 CM=4 EV=ed" }, 

 // variable object 4: 

 { "@Pvi/PviSimple/ARsim/Cpu/ctrlMain/Sugar", POBJ_PVAR, 

  "CD=gRecipe.Sugar RF=2500", "VT=i32 CM=4 EV=ed" }, 

 { NULL } };  // -> end of list indicator 
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4.2 PVI Monitor 의 추가 기능 

Sample 과 Coffee machine 이 정상 구동을 하고 있을 경우 

 

 
 

1) Options > PVI Diagnostics 선택 
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2) 파일을 저장할 Path 선택, Snapshot 선택 

 
 

3) Options > PVI Snapshot Viewer 선택 

File > Open Snapshot File 로 이전에 저장한 파일 선택 
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4) 현재 통신중인 변수의 상태를 확인 할 수 있음. 
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5) 동일하게 보이지 않을 경우 File> Make Topical Snapshot 을 눌러 현재와 동일하게 수행되도록 함. 
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5 참고자료 

5.1 Help 

 C:\BrAutomation\PVI\V4.2\Help 

 
 

 B&R Automation Studio Help 
 Communication > PVI 
 Communication > PVI Services 
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5.2 샘플 소스 위치 

샘플 소스 위치 1 

C:\BrAutomation\PVI\V4.2\Samples\PVI 에 샘플이 설치됩니다. 

설치하신 PVI 버전에 따라 주소 위치가 변경 될 수 있습니다. 

 

 
 

 
 

샘플 소스 위치 2 (C#, PVIServices) 

C:\BrAutomation\PVI\V4.2\PVI\PviServices 에 샘플이 설치됩니다. 

설치하신 PVI 버전에 따라 주소 위치가 변경 될 수 있습니다. 

 
 

 
 

 

5.3 DLL 파일 위치 

DLL 파일 위치 

C:\BrAutomation\PVI\V4.2\PVI  
 

설치하신 PVI 버전에 따라 주소 위치가 변경 될 수 있습니다. 
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C:\BrAutomation\PVI\V4.2\PVI\PviServices\VS2008\win32 
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